https://github.com/nixtla logo
a

Afiq Johari

06/28/2023, 3:24 PM
Hi I'm following through the available tutorials, currently trying out the "Hyperparameter Optimization" tutorial This particular line gives out a missing file error. I appreciate if I can get some guidance on how to sort this out. I'm on python 3.10, and have created a fresh conda environment specifically for neuralforecast.
nf.fit(df=Y_df, val_size=24)
Copy code
>>> nf = NeuralForecast(models=[model], freq='M')
>>> nf.fit(df=Y_df, val_size=24)
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "C:\Users\user1\anaconda3\envs\neuralforecast-env\lib\site-packages\neuralforecast\core.py", line 238, in fit
    model.fit(self.dataset, val_size=val_size)
  File "C:\Users\user1\anaconda3\envs\neuralforecast-env\lib\site-packages\neuralforecast\common\_base_auto.py", line 182, in fit
    results = tune_model(
  File "C:\Users\user1\anaconda3\envs\neuralforecast-env\lib\site-packages\neuralforecast\common\_base_auto.py", line 71, in tune_model
    results = tuner.fit()
  File "C:\Users\user1\anaconda3\envs\neuralforecast-env\lib\site-packages\ray\tune\tuner.py", line 347, in fit
    return self._local_tuner.fit()
  File "C:\Users\user1\anaconda3\envs\neuralforecast-env\lib\site-packages\ray\tune\impl\tuner_internal.py", line 588, in fit
    _global_node = ray._private.node.Node(
  File "C:\Users\user1\anaconda3\envs\neuralforecast-env\lib\site-packages\ray\_private\node.py", line 290, in __init__
    self.start_ray_processes()
  File "C:\Users\user1\anaconda3\envs\neuralforecast-env\lib\site-packages\ray\_private\node.py", line 1213, in start_ray_processes
    resource_spec = self.get_resource_spec()
  File "C:\Users\user1\anaconda3\envs\neuralforecast-env\lib\site-packages\ray\_private\node.py", line 459, in get_resource_spec
    self._resource_spec = ResourceSpec(
  File "C:\Users\user1\anaconda3\envs\neuralforecast-env\lib\site-packages\ray\_private\resource_spec.py", line 175, in resolve
    num_gpus = _autodetect_num_gpus()
  File "C:\Users\user1\anaconda3\envs\neuralforecast-env\lib\site-packages\ray\_private\resource_spec.py", line 287, in _autodetect_num_gpus
    lines = subprocess.check_output(cmdargs).splitlines()[1:]
  File "C:\Users\user1\anaconda3\envs\neuralforecast-env\lib\subprocess.py", line 421, in check_output
    return run(*popenargs, stdout=PIPE, timeout=timeout, check=True,
  File "C:\Users\user1\anaconda3\envs\neuralforecast-env\lib\subprocess.py", line 503, in run
    with Popen(*popenargs, **kwargs) as process:
  File "C:\Users\user1\anaconda3\envs\neuralforecast-env\lib\subprocess.py", line 971, in __init__
    self._execute_child(args, executable, preexec_fn, close_fds,
  File "C:\Users\user1\anaconda3\envs\neuralforecast-env\lib\subprocess.py", line 1456, in _execute_child
    hp, ht, pid, tid = _winapi.CreateProcess(executable, args,
FileNotFoundError: [WinError 2] The system cannot find the file specified