Hi team, I am using NeuralForecast with AutoNBEAT...
# neural-forecast
Hi team, I am using NeuralForecast with AutoNBEATS, AutoNHITS and AUTOTFT and it seems to me that during training just one core is used. I tried modifying 'cpus' parameter but still the same. Is this behaviour to be expected or am I missing something? Thanks.
Hey. Are you using ray or optuna?
Hi, I experienced the same behaviour as @A. It always show 1 cpu core is used and training seems to take a long time. I was using Ray on CPU (no access to GPU),
from ray import tune
from ray.tune.search.hyperopt import HyperOptSearch
hey @José Morales, I am using ray as well.
Can you try providing
? Seems like that option controls the resources of each trial, so if you set it to all your cpus (the default) it can just run one trial concurrently
👍 1
@José Morales Don't really understand what you mean, what is the purpose of 'cpus' then? But it works by setting cpus=1 ☺️
It's used to control the resources that the trials for a model will take. By default ray will try to use all available CPUs when running the optimization, so if you tell it that ModelX needs all of your cpus (by doing
) then it can only run one trial at a time, whereas if you set
then it can parallelize the trials
👍 2